Week of Feb 21, 2010 IMP::Object::set_was_owned() was changed to IMP::Object::set_was_used() as that better reflects what the flag means. various more interpolation and endian methods had their names fixed (by adding get_) the function get_mean() on vectors was removed as it duplicated IMP::algebra::get_centroid() build_Transformation3D_from_transformation3D was replaced by IMP.algebra.get_transformation_3d() IMP::algebra::almost_equal() is now IMP::algebra::get_are_almost_equal() to fit the naming conventions. the random vector generators have been cleaned up to remove redundant ones and make the names more consistent. They now have the form of either IMP::algebra::get_random_vector_in() or IMP::algebra::get_random_vector_on() where there is one argument describing the volume or shape (such as an IMP::algebra::SphereD<4>). or IMP::algebra::get_uniform_surface_cover() where the first argument is the primitive whose surface we are covering and the second is the number of points. Some good sed strings are Spheres in IMP::algebra are now supported in general dimensions. See IMP::algebra::SphereD. Many methods in IMP::algebra were renamed to be more consistent with other methods or general conventions. Most of these simply involved addingget_ as a prefix and/or add a _3d suffix when they did not take any arguments. build_Rotation2D_from_Vector2D became IMP::algebra::get_rotation_to_x_axis() most of the Rotation3D and Transformation3D functions (in addition, IMP::algebra::get_identity_rotation_3d() andIMP::algebra::get_identity_transformation_3d() added the _3d so we can add 2D versions at some point) IMP::algebra::Transformation3D::get_transformed() and IMP::algebra::Rotation3D::get_rotated(). IMP::algebra::get_distance(), this also carries over to the IMP::core::get_distance() The following global replacements are probably safe (in sed expressions) IMP::algebra::Vector3D and IMP::algebra::Vector3Ds were replaced by the expanded (non-typedef) version in functions parsed by SWIG as the current situation was extremely brittle. For the moment, you should not use the typedefs in definitions that swig sees. Sorry. IMP::algebra::Sphere3DPatch was renamed to IMP::algebra::SpherePatch3D to be consistent with the other geometry and allow us to support higher dimensions in the future. rigid_align_first_to_second was renamed to IMP::algebra::get_transformation_aligning_first_to_second() and build_Transformation2D_from_point_sets was renamed to IMP::algebra::get_transformation_aligning_pair()
Sed substituions are included in the change log.