Daniel Russel wrote: > Add operator[] to Vector3D as that is kind of customary in C++
True - there's no reason really to have get_component() in this case. (operator[] can be trivially renamed to __getitem__ in IMP.i.) I also got rid of the #ifdef - the preprocessor is evil... and SWIG can just as easily be asked to %ignore (or, in future, %rename) the method.
> Make some clarifications in the documents about what show and other > things should do. And remove the > name from the Optimization state since it is never used. We may want to > put the name into object so that everything has it, but the current > system with a few random objects having it is kind of awkward.
I don't really see the point in anything having a name, except for restraint sets (perhaps). Your patch didn't actually seem to completely kill OptimizerState::name_, so I modified it a little.
> Add a singleton score function that applies a unary function to the > value of a single attribute.
A unit test for this one would be great...
Ben