Patch 583 doesn't really make sense. Either it should become "if (table.contains()) table.remove" and remove always should be removed or remove_always should be fixed to do bounds checking.
I think prefer the first.
Daniel Russel wrote: > Patch 583 doesn't really make sense. Either it should become > "if (table.contains()) table.remove" and remove always should be removed > or > remove_always should be fixed to do bounds checking.
I didn't do the first, because that would duplicate the check. Since you already provided a method which did not duplicate the check (remove_always) I used that.
If you don't want a method that skips the bounds check, by all means submit a patch to remove it. But I only used what was provided in the first place. ;)
Ben
participants (2)
-
Ben Webb
-
Daniel Russel