On 11/20/12 6:32 AM, sdimicco wrote: > class dope_loopmodel(dope_loopmodel):
While this *might* work, it'll be confusing to people reading your script. Normally, you would use a different name for your derived class, e.g.
class MyModel(dope_loopmodel): ...
a = MyModel(...)
> a.make() > > automodel.final_malign3d = True
This last line will have no effect, since you set the flag after you call make(). If you want to do a final malign3d, do
a.final_malign3d = True a.make()
> Moreover, I built a model with an HETATM residue. If I want to treat it > as flexible residue: how could I do that?
You'd have to make a new residue type (or get the parameters from an existing source) and use the new one letter code in the alignment. See http://salilab.org/modeller/9.11/FAQ.html#8
Ben Webb, Modeller Caretaker