[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [modeller_usage] Error when using dope_loopmodel

Florian Odronitz wrote:
Please note that I used the dope_loopmodel class instead of loopmodel as indicated in the manual.
When I run the script, it exits with the following message:
check_inf__E> Atom 4293 has out-of-range coordinates (usually infinity).
               The objective function can thus not be calculated.

Using dopehr_loopmodel gives the same error whereas the "old" loopmodel works.
Here is the Atom record from the PDB file:

	ATOM 4293 N LEU 535 10.568 18.659 81.951 1.00103.06 1SG4294

The coordinates do not seem to be out of range. I also put a blank in the middle ("1.00 103.06") to avoid problems with the parser, but to no avail.

The error refers to the current set of coordinates (during optimization) - not the initial PDB coordinates. And don't put a blank into the PDB file - PDB files are fixed-column format, so it doesn't matter that there's no space between 1.00 and 103.06 (in fact, your "fixed" PDB file is now invalid).

An atomic coordinate at infinity is usually a symptom of large forces in your system. These can occur if you have a bad initial model (e.g. two atoms superposed or very close). It is more likely to occur with DOPE loop modeling than regular loop modeling since the former includes GB/SA. (The loop modeling potentials themselves, while they are atomistic pair potentials, plateau as r tends to 0, unlike electrostatic potentials which tend to infinity.)

Am I doing something wrong here or is this a bug?

Could be either. You can try a different initial model if your initial model is very bad. Otherwise, send me your input files and I'll try to reproduce your problem, to determine whether it's a bug in the GB/SA code.

	Ben Webb, Modeller Caretaker
Modeller mail list: http://salilab.org/mailman/listinfo/modeller_usage