[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [modeller_usage] Parallel modeller

I have checked more carefully, I have socket in my python2.5
distribution, but still when I run my script using python (instead of
mod9.5) I have a regular output at the end of which I get the following:

<< end of ENERGY.
openf___224_> Open           NPY2_on3eml_loop.IL00000001.pdb
wrpdb___568_> Residues, atoms, selected atoms:      301     2398     2398
Running 10 tasks on 3 slaves
mod9v5 -slave >& loopmodel.slave0
mod9v5 -slave >& loopmodel.slave1
mod9v5 -slave >& loopmodel.slave2

And the terminal stays on standby, although no process is running on my
computer. If I manually try to run each of this lines, I get again the
error of "no module named socket", while if I run each of this lines
with python instead of mod9v5 I get again the terminal on standby, as if
it was running, but with no process on my computer running.

Thanks for help,


Modeller Caretaker wrote:
> On 10/09/2009 04:31 AM, Hugo Gutiérrez de Teran wrote:
>> I want to run parallel job on my Quadcore. I used as a template the
>> script provided in the examples/automodel/model-parallel.py
> ...
>> ImportError: No module named socket
> Did you read http://salilab.org/modeller/FAQ.html#19 ?
>     Ben Webb, Modeller Caretaker

Hugo G. de Teran, PhD.
"Parga Pondal" Research fellow
Fundación Pública Galega de Medicina Xenómica - SERGAS
Santiago de Compostela (SPAIN) 

Phone +34 981563100 ext 13873
e-mail:       http://web.usc.es/~hugogdt