Added densityMapVolumetrics{.cpp/.h} files to the IMP::em module They provide - functions to compute mass/volume of a densityMap at a given threshold - functions to compute the threshold one needs to apply in an EM map to attain a given mass/volume In addition, one can use different protein density values in these computations. The default density being used remains 1/1.21 Da/A^3, the value that was used since then.
A small duplication issue remains to leverage : DensityMap::approximate_molecular_mass() should probably disappear or be remapped on compute_molecular_mass_at_threshold( DensityMap* m, Float threshold);
Shall I do it ?
--Ben(S)
On 3/7/11 7:25 AM, Benjamin SCHWARZ wrote: > Added densityMapVolumetrics{.cpp/.h} files to the IMP::em module
Looks OK to me. Just one minor formatting quibble: IMP variable names and headers that don't implement a single class should be named with lower case words separated by underscores. So your header/cpp files should really be called density_map_volumetrics or similar. Same for some of your variables - e.g. volumeDesired should be volume_desired (or desired_volume - you seem a bit inconsistent there ;).
> A small duplication issue remains to leverage : > DensityMap::approximate_molecular_mass() should probably disappear or be > remapped on compute_molecular_mass_at_threshold( DensityMap* m, Float > threshold);
I'd be tempted to just get rid of it, unless there are people who are using it who disagree.
Ben
participants (2)
-
Ben Webb
-
Benjamin SCHWARZ